Importing your data into SIMS .net

Before doing the import into SIMS .net it is always advisable to do a full SIMS backup, for safety. Ensure that you consult your SIMS documentation and any local guidelines that are available.

Please note that the information given here is correct to the best of our knowledge, and it may change at any time, so you should always download the latest version of this document, via www.timetabler.com/ExportMenu You should refer to any relevant SIMS documents and any guidelines provided by your local/county SIMS Support Team.

The import described in this document is directly from TimeTabler to SIMS .net.
(There is also an older alternative transfer from TimeTabler to Nova-T4, no longer recommended.)

For questions about Registration (and Breaks, Lunches) see the PDF about 5 different Styles, found in the KnowledgeBase by using the Search Box:

Contents

page

2 – 3 Importing into SIMS .net; Checking Staff timetables
4 Assigning Students to Teaching Groups
5 Printing Class Lists from SIMS .net; Printing Student timetables; Making Room changes
6 2-stage (double) importing
7 Re-importing a timetable from TimeTabler
8 Levels
10 – 11 Trouble-shooting : Logs & Reports
12 – 21 Trouble-shooting : Questions & Answers
Importing into SIMS .net

The final step in the previous document, ‘Export Document 2’, was:

You need to make sure you are on a PC with access to SIMS .net and the ‘SIMS Transfer Wizard’.

Complete the details correctly for your system.

It is possible that the SIMS import wizard (called CurrMatch.exe) may not be at: C:\Program Files\Sims\Sims .net\CurrMatch.exe but on some other drive.

Then click on Send Timetable. This connects you to the SIMS import ‘wizard’, which takes you through the import process.

You may need to set up the ‘cycle’ information for SIMS first, by a first pass as explained in items 4 – 9 on pages 12-13. More details in item 4 on page 12. Warning: only use ‘Send Cycle’ once in an academic year, otherwise it can erase your attendance, cover data, etc in SIMS.

Note: If you are using a ‘Hosted’ version of SIMS, see also the ‘Questions & Answers’ section.

In SIMS .net

The following screen shots give you an idea of the sequence which follows, within SIMS .net, but for more details please consult your SIMS Help files, or the SIMS HelpDesk, or your local/county SIMS Support Team.

A. Welcome Screen
This summarises what you are importing and lists any unknown teacher codes. These won’t stop the import, but these teachers will be ignored, and all their lessons will have ‘no teacher’ in SIMS.

B. Submission Summary Screen
This lists any changes to a re-imported timetable structure and shows you which items are not linked.
C. Merge Curriculum Screen
The **TimeTabler** structure (being submitted) is shown at the left, and any current structure in SIMS is shown at the right:

If you are importing this timetable for the first time, then the right-hand side will be blank.

If you are re-importing a timetable then see the ‘Re-import’ section on page 12.

Filters allow you to modify the display (eg. to show ‘Unlinked’, ‘Changes only’, or ‘All items’).

Right-clicking on a part of the structure allows you to expand or collapse parts of the structure.

Click on Help for more details.

---

D. Verify Changes Screen
This shows you any modifications.

---

E. The data is then submitted to the SQL database:

---

**Staff timetables**

You can now view the **Staff Timetables**, to check that they have imported OK, via Focus ➔ Person ➔ Manage Classroom Staff ➔ Search.

Double-click on a Teacher, then click on **Staff Timetable** (under Links, at the right-hand side).

The next step is to allocate Students to Teaching Groups (called ‘classes’ in SIMS) for which they are eligible. This is outlined on the next page.
Allocating Students to Teaching Groups

You should then allocate Students to Teaching Groups (called ‘classes’ in SIMS) for which they are eligible.

Start at: Focus ➔ School ➔ Academic Structure ➔ Curriculum Assignment by Scheme ➔ Search.

You will be shown a list of ‘schemes’, similar to:

<table>
<thead>
<tr>
<th>Name (of scheme)</th>
<th>Type</th>
<th>Sourced by</th>
<th>Destination Groups</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Groups in Year 7</td>
<td>Band</td>
<td>Year 7</td>
<td>7A, 7B, 7C, 7D</td>
</tr>
<tr>
<td>7AB (w)</td>
<td>Band</td>
<td>7A, 7B</td>
<td>7AB (w)</td>
</tr>
<tr>
<td>7ABCD (z)</td>
<td>Band</td>
<td>7A, 7B, 7C, 7D</td>
<td>7ABCD (z)</td>
</tr>
<tr>
<td>7ABCD Ma</td>
<td>Block</td>
<td>7ABCD</td>
<td>7zMa1, 7zMa2, 7zMa3, 7zMa4</td>
</tr>
<tr>
<td>7ABCD Block K</td>
<td>Block</td>
<td>7A, 7B, 7C, 7D</td>
<td>7zArK1, 7zMuK1, 7zDrK1</td>
</tr>
<tr>
<td>7AEn1</td>
<td>Cluster</td>
<td>7A</td>
<td>7AEn1</td>
</tr>
</tbody>
</table>

To assign students to the Teaching Groups (classes), follow these steps (using the examples above):

a) Assign the Basic Groups in Year 7
   Double-click on ‘Basic Groups in Year 7’ and assign each student in Year 7 to his/her ‘group’.
   In Lower School these ‘groups’ will typically be the tutor-groups / registration-groups (7A, 7B, etc).
   (In Upper School these ‘groups’ could be half-year-bands, etc).
   It just depends how you entered your scheduling names in Timetabler. They are the ‘simplest’ class scheduling names you entered for this year, from which all other scheduling names can be built up.

b) Assign the Bands in Year 7
   Double-click on 7AB (w) (in the example above) and assign each student in 7A and 7B to band 7AB.
   Since this is all the students on the screen, to the only destination group, you can do this quickly (rather than tick every student) by:
   Action ➔ Select All Students, and then:  Action ➔ Tick Selected Cells.
   Do similarly for all the other bands.

c) Assign the Blocks in Year 7
   Double-click on 7ABCD Ma and assign each student in 7A, 7B, 7C, 7D to one of the 4 Maths groups.
   And similarly for other blocks.

d) Do the same for other year-groups.
Printing Class Lists in SIMS .net
You can use : Reports ➔ Student list ➔ Class lists and then a wizard to select what you’re looking for.

Viewing Student Timetables
Go to Focus ➔ Student ➔ Student Details, and then click on ‘Search’ to list the students. Double-click on the student you want. Click on ‘Timetable’ (under the ‘Links’ section at the right-hand side).

Printing timetables
To print (or print preview) a timetable, go to Reports ➔ Print Timetables and then select from the choice of :
- Staff Timetables, or
- Student Timetables, or
- Room Timetables.

Follow the on-screen instructions thereafter (it takes you through several more screens asking you to select the specific teacher/student/room, whether you want individual or spreadsheet style, confirm your date ranges, etc).

Making Room Changes etc
Go to Focus ➔ School ➔ Academic Structure ➔ Edit Lesson Staff and Rooms.
2-stage exporting

SIMS .net (and some other MIS) allow you to do a 2-stage export ...and this can be very helpful for your admin staff, and for you in ensuring a smooth export.

A 2-stage export consists of:
- a 1st export after the Batches have been entered, eg. in April, but before the activities have been scheduled. This allows your admin colleagues to begin allocating students to Maths Sets or to groups in Option blocks (i) using the correct Teaching Group Names and (ii) without having to wait until you have finished scheduling.
- The 2nd stage of the export takes place after you have a complete timetable solution, and it exports the correct timetable data for each Teaching Group ...providing the Teaching Group Name has not changed!

There are 2 advantages of the double-export method:
1. Your office staff can get busy allocating students to groups without waiting for you to finish the complete timetable,
and
2. If the office staff start using Teaching Group Names which are not the same as the ones that you will export from TimeTabler then SIMS will not be able to match the two sets of names during the import, and this will cause you a lot of problems.
However, if you export the Teaching Group Names to SIMS before your admin staff start assigning students, it means that they will use the correct Teaching Group Names and so the names will be recognised by SIMS during the import of the completed timetable (on the Merge Curriculum Screen, page 3). This will make life easier for you.

Note:
If you are doing a 2-stage Export to SIMS .net, it is vital that the Teaching Group Names do not change between the 1st and 2nd exports, or else SIMS will probably not recognise the Group Names. (There is no way to change group or class names in SIMS.)
The danger if the classes are not recognised is that any work done on assigning students to Classes/groups will be lost and have to be redone. This can be very tedious.
On the Merge Curriculum screen (see the next page) when you are importing the timetable you have the ability to match unrecognised groups, but only if the structure has not changed.

Checking your Teaching Group Names:

Before the export:
To see what your Teaching Group Names (TGNs) will look like, go to the Curriculum Diagram Screen (section D22 in the TimeTabler Manual) and select: Customize ➔ TGNs ➔ Show TGNs in Batches

After the export:
To see what Teaching Group Names have actually been exported, see the report file called Teaching-Groups.htm which is available at File ➔ Export your Timetable to... ➔ View Logs.
More details are given in the Trouble-shooting section.
Re-exporting your Timetable

During the school year, you may wish to make a change to your timetable (in TimeTabler) and then export this new timetable, and import it to SIMS.net. The export has a feature that allows you to do this re-export. To avoid having to then re-assign all your students, the export will attempt to match (where possible) classes in the timetable with those in the existing timetable in SIMS.

If you are only making small changes to your timetable (eg. room changes) then it is better to make these changes in SIMS.net.

Whatever changes are made in SIMS should also be made in TimeTabler otherwise a subsequent larger change to the timetable will have no knowledge of these changes. (For schools that use NovaT6 to store the timetable after using TimeTabler to find a good solution, then the changes can be made in NovaT6.)

How to re-export:
The way you instruct TimeTabler to attempt the matching is to perform an export in the usual way, but at Step 6 of the export, tick the box that says: [ ] If this is a re-import, tick here.

Important note:
The re-export relies on matching IDs passed back from SIMS to TimeTabler during the original export ...so you must be on the same PC as you performed your previous export to SIMS.net, and you must not have uninstalled TimeTabler in the meantime, nor have deleted any of the files in its export folder (usually at C:\TT4Win\Export).

Warning!
Please, as always, make a full backup of your SIMS data before attempting a re-export!

Merge Curriculum Screen (see also page 3 above)

When you imported the timetable for the first time, the right-hand side of this screen was blank.

When you are re-importing a timetable then this screen can be used to manually link the new curriculum structure with the old one, by clicking on the 2 items to be linked and then clicking on the $\leftrightarrow$ Link button.

If you opted for automatic linking at Step 6 then there may be few or no items to link here.

Check the re-import
The success of this matching will depend on how radically you have changed your timetable, and whether the curriculum structure has changed significantly. After re-importing, you should check your staff and student timetables in SIMS as you may find you need to re-assign some students to some classes.
‘Levels’ codes in SIMS .net

There are over 100 (!) possible codes for the Levels in SIMS .net at the time of writing. A ‘course’ is defined as a Subject + a Level.

By default TimeTabler inserts ‘KStg3’ as the Level for Years 7, 8, 9; ‘GCSE F’ for Years 10 & 11; ‘GCE AS’ for Year 12; ‘GCE A’ for Year 13 ...but you can change the Level during the Export (eg. if some of your courses are for the IB). See step 9 of the export.

At the time of writing the Levels seem to be needed only for the ‘Post-16 census return’.

It is essential that these Levels are set correctly in the Export to SIMS to avoid errors with the Post-16 census or a large amount of corrective work at a later date.

After the import you can view the Level in SIMS .net at Tools ➤ Academic Management ➤ Course Manager ➤ Maintain Course. Unfortunately SIMS .net will not allow you to edit the Level.

To correct a Level, see the Note below.

There are more details of the Levels in the Capita SIMS booklet ‘Managing Courses’, pages 79–84. It is available in the timetabler section of the Documentation, accessed through the Home Page of SIMS .net. The Levels table is now maintained in Course Manager in SIMS .net.

Later advice (2019):

In SIMS, Levels are used to manage groups of students for Exams, Assessment Manager and Profiles.

Schools are now generally moving away from the AS/A2 model and teaching 2-year Linear A levels.

This means that it is essential that they use the same Level for the Year 13 class that they used for the Year 12 class from the previous Academic Year.

The default Level for both Year 12 and Year 13 is GCEA. [Another level was created in SIMS to help with managing the changeover from AS/A2 to Linear A levels: GCE2Y]

Note: If a mistake is made then it becomes more difficult to correct it after the Academic Year has started because SIMS does not accept a change of Level of a class unless you are changing it for the whole of the date range for which it has been set.

For example, if the timetable has been exported with dates from 01/09 to 13/07 then sending for the same date range again will allow the Level of a class to be changed, but if a new send is 21/09 to 31/07 it will not change the Level of the class in SIMS because the class is a member of the Course for dates outside the dates of the export.
The next pages describe the Reports that are available for trouble-shooting ...and even more usefully they list some of the Error Messages that may be seen in SIMS .net, together with solutions to the problems.
Trouble-shooting

If you get any error message during the export from TimeTabler or during the import into SIMS, or if you find that some or all of the timetable does not appear in SIMS, then the first things to do are to look at the diagnostic information that TimeTabler provides.

These Logs and Reports are summarised on these pages.

These files can be viewed at Export to... ➔ View Logs:

They can also be found in the Export folder within the folder where TimeTabler was installed.

These files include:

Main Export Log Exp Log.txt
This analyses and summarises your export data, see some of the headings below:

If anything looks at all wrong, please ensure that you correct it before trying another export.
Trouble-shooting, continued

Teaching-Groups.htm
This useful page lists for you every activity that has been exported, with:
- the short 'Label' used in SIMS, see Section G in the Export-Doc-1 ‘Preparing for Export’ document,
- a longer 'Description', which may also be used in SIMS,
- the activity that you scheduled in TimeTabler,
- the times of the week that the lessons are placed.
This is very useful for checking the imported timetable in SIMS.

SchemeList.htm
This diagnostic gives a list of the exported schemes.
This is relevant to the 'eligibility' of the students to be placed in a Teaching Group.

Block IDs.txt
This summarises:
- Activities that have a Block Label,
- Activities that do not have a Block Label.
See also Section G of the Export-Doc-1 ‘Preparing for Export’ document.

TTresult.xml
SIMS also gives Log files, like this XML file:
it includes a list of 'unknown' Teachers and Rooms that SIMS does not recognise!
More Trouble-shooting : Questions and Answers

1. If I ask for help from our local /county SIMS Support Team, what do they need to know?

If you involve your local/county SIMS Support Team to help you with the import into SIMS then you may wish to emphasise to them that:

- **TimeTabler** uses exactly the same ‘CurrMatch’ Curriculum Matching Import Wizard as used by Nova T6.
  ie. **TimeTabler** produces a file with the same format as T6.
- This is with the full agreement of Capita-SIMS. We are an official Capita-SIMS Partner, and they supplied us with the information and documentation to produce this export.

2. What is a ‘Double-import’ ? And why should I do it ?

A ‘double-import’ or ‘2-stage’ import can be a key factor in ensuring a successful transfer of data. Please see the full reasons why you should do this, on page 6.

3. My office staff are having difficulty assigning students to Teaching Groups ...because they don’t recognise the Teaching Group Names imported from **TimeTabler**.

In **TimeTabler**, you should go to File ➔ Export the timetable to... ➔ View logs ➔ Exported Teaching Groups and print this list of all the Teaching Groups to give to your office staff. Please then find time to sit down with them and the printout and explain the terminology that you have used in **TimeTabler**.

The ‘Label’ and the ‘Description’ are both exported to SIMS – the ‘Description’ is longer and more descriptive, but often the SIMS screen shows just the label.

**Note:** any Teaching Groups marked in red in this list are ones where perhaps you should have labelled them differently (by using a BlockID or GlobalDayBlockCode or Set Number). For more details on this, see sections G and H of the first document, ‘Export-Doc-1’.

4. I am getting error messages related to the ‘Cycle’ #1

If this is the first year you have used SIMS.net (or you are using a different number of periods in the new timetable ...or for any other reason, you do not have the basic weekly-cycle information in SIMS.net) then you may need to export the timetable in 2 passes:

Pass 1: the ‘cycle’ information only.
Pass 2: the actual timetable.

**Pass 1** means that you tell SIMS.net the number of days/periods in your week, but you don’t yet send it the actual timetable.

To do this, follow these steps:

a) Perform the export in the usual way, and at Step 8 click on “Connect to SIMS” as usual
b) In the **Send**: box change ‘Timetable’ to ‘Cycle only’.
  c) Click on ‘Send Timetable’, as usual.

Then in **Pass 2**, repeat the export in the usual way to export the actual timetable (ie. do not change ‘Timetable’ to ‘Cycle only’ this time).

**Note:** This is a common error in SIMS.net (it affects any school new to SIMS.net, or any school trying a different number of days/periods from the previous year). **Warning:** only use ‘Send Cycle’ once in an academic year, otherwise it can erase your attendance, cover data etc in SIMS!

5. I am getting error messages related to the ‘Cycle’ #2

On the Prepare Data screen (Step 3 of the export), check that the Shape page accurately describes the week that is in SIMS. See page 6 in Export-Doc-2.
6. I get a message: Windows cannot find C:\Program Files\Sims\Sims .net\CurrMatch.exe
   A second message gives details of the username and password that you entered.
   At Step 8 of the export you have not entered the correct location of the SIMS CurrMatch.exe import program, or else your computer cannot access the network with the SIMS server, or else you have mis-typed the user-name, the password, or the path-name.
   Use ‘Search’ on your computer network to find the correct location; make sure that you are running Timetabler on a machine that has access to SIMS; and check the typing.

7. I get an error message:
   ‘Error: Supplied date range must lie within a single timetable cycle definition’
   This means the date range that you are supplying is falling between 2 different timecycle models in the school’s database, and is a sign that the cycles set up in SIMS .net are not correct / don’t match the dates that you specified in the Timetabler export.
   Either: If this is your first year of using SIMS.net, use the same solution as number 4 above.
   Or: If you have used SIMS.net before, the date range that you are supplying is falling between 2 different timecycle models in the school’s database.

8. This is the first year I’ve used SIMS.net – do I need to anything ?
   Yes – you will almost certainly get the message shown in number 4 above. So perform the two-pass solution described in solution number 4 above.

9. What does a ‘25+5 period cycle’ mean in the SIMS transfer wizard ?
   ‘25+5’ is SIMS .net’s way of presenting a weekly cycle with 25 teaching periods plus 5 non-teaching periods. For example, (5 days) x (5 teaching periods + 1 registration period).
   This must be the same in Timetabler as in SIMS .net.
   If they are not currently the same, you need to decide which is correct (Timetabler or SIMS.net)
   If Timetabler is correct: use the 2-pass method described in Number 4 above.
   If SIMS.net is correct: use the ‘Shape’ page of the ‘Prepare Data’ screen (Step 3 of the export) to make Timetabler the same as SIMS .net.
   This ‘25+5’ may also be presented in the Import Wizard as follows:
   Teaching periods in Cycle : 25
   All periods in Cycle : 30

10. What is a ‘Teaching Group’ ? What is a TGN (Teaching Group Name) ?
    A Teaching Group is a specific ‘class’ being taught a specific ‘subject’ (and optionally with a ‘Block ID’ and ‘Set number’).
    Change any of those (4) variables and you have a new Teaching Group.
    Examples are:
    7A / Fr 1    (7A being taught French),
    10A / Ma1    (10A being taught Maths Set 1),
    9C / Hi3B    (9C being taught History, 3rd History group in Block B),
    11z / Ma2    (11ABCD Maths Set 2, where 11ABCD has been given the ‘band-letter’ z)
    See also sections G and H in Export-Doc-1.
    Although Teaching Group is the usual word for this, SIMS may use ‘class’, ‘group’, or ‘cluster’.
    continued...
11. Can I change the Teaching Group Names?
Yes, see Step 5 of the Export, where you can customize the look of your Teaching Groups. eg. 7A/Fr1 7A .Fr1 7A-Fr1 7A|Fr1 7AFr1
You can also change the names by adding BlockIDs, set-numbers, band-letters, etc.

The best way to see how the Teaching Groups fit into your curriculum and relate to your activities is to view the Curriculum Diagram Screen (section D22 in the *TimeTabler* Manual).

12. The Teacher-codes in SIMS are different from the initials in *TimeTabler*
Use the ‘Prepare Data’ screen (see Step 3 of the export).

13. I get a message: ‘UNRECOGNISED TEACHER CODE’
If teacher KJo were unrecognised, there are 5 possible reasons / solutions:

<table>
<thead>
<tr>
<th>Reason</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>KJo doesn’t exist in SIMS.net</td>
<td>Enter him in SIMS now.</td>
</tr>
<tr>
<td>KJo exists in SIMS.net but has been entered differently (eg. different spelling or more letters used)</td>
<td>Either change him in SIMS.net – or, if this is inconvenient - use the ‘Prepare Data’ screen (Step 3 of the export) to change the way he is exported from <em>TimeTabler</em>.</td>
</tr>
<tr>
<td>KJo is in SIMS.net, but is not registered as a ‘Classroom’ teacher</td>
<td>When setting-up your teachers in SIMS, you have to make sure that the teachers are all visible when you go to ‘Focus ➜ Person ➜ Manage Classroom Staff’. ie. it is not enough for them to simply be in the list of teachers you get at ‘Focus ➜ Person ➜ Staff’.</td>
</tr>
<tr>
<td>KJo is in SIMS.net, but his valid dates do not cover the range of the timetable being imported</td>
<td>Change his dates in SIMS.net to ensure he is entitled to be on the timetable.</td>
</tr>
<tr>
<td>KJo is in SIMS.net, but because he is not joining until September, he does not yet have a current valid date. It seems there is a fault in SIMS.net that sometimes teachers that are starting in Sept (and so have been entered in both <em>TimeTabler</em> and SIMS.net and are on the timetable) cannot be given any lessons in SIMS.net. Even though you’ve told SIMS they’re starting in Sept, you can’t give them a timetable for Sept (or for any time).</td>
<td>Change the date, or re-import the timetable into SIMS.net on the first day of term in September!! This should not be a problem as long as the teacher has been set up with a start date of the first day of the Academic year and has been set up correctly in Manage Classroom Staff. Sometimes the problem arises because the Personnel Officer in school does not put teachers into SIMS until the day they start.</td>
</tr>
</tbody>
</table>

Note: If you don’t correct these mismatches, the Wizard still allows the import to proceed, but any class being taught by an ‘unrecognised teacher code’ will have no teacher in SIMS.net.
14. I don’t want to export a particular class

Give it a printing name of *D in TimeTabler (see section C12 in the Manual).

Special Locations and ‘Staff timetable labels’ can (optionally) be exported to SIMS. If you want to export them, then at Step 3 of the export, click on “Prepare your Basic Data” then on “Non-teaching” and follow the instructions.

Special Resources are never exported.

15. I have used Year 1 to represent not just Year 1 but Reception too

SIMS will almost certainly expect these groups to be represented as two separate years, and so you will need to follow these steps to separate them in TimeTabler too:

If you have used Year 1 to also represent Reception (and/or Nursery 1 and Nursery 2)

eg. 1A, 1B = Year 1 and 1a, 1b = Reception,

and if SIMS is expecting instead that Reception is a separate year, with a separate cohort of students, then you will need to:

a) Add an extra year to represent Reception (eg. if you currently have 1-6, add a Year 7).
b) Print the timetable for Year 1.
c) Unassign the lessons for Reception.
d) In the classes list, change 1a to 7a, 1b to 7b (giving 7a the printing name R1, say).
e) Globally update the batches 1a to 7a, etc (via ‘Activities ➔ Update Batches Globally’).
f) Go back into the schedule and assign 7a’s lessons to where (according to your printout) 1a’s were.
g) When you start the export ... on the ‘Prepare Data’ screen (Step 3), click on ‘Years’ then enter ‘R’ against Year 7. (Or similarly ‘N1’ or ‘N2’ for the nursery years).

Obviously it is better to use a separate year right from the start (see section A in Export-Doc-1).

16. I have used ‘dummy teachers’ in TimeTabler to represent something

If you have ‘teachers’ called ‘Lunch’ or ‘Break’ in your Teachers list (section C9 in the Manual) or if you have included rooms in your teacher list, this would cause problems if they were exported to the MIS, as they would not be recognised.

So please clean these up in TimeTabler before you export (by assigning their lessons a different way, or at least putting *D against the dummy teachers so they’re not exported).

Special Resources are never exported.

17. I get the message ‘unrecognised levels’

The level you have added (perhaps as free-format, at Step 6) in TimeTabler is not in SIMS .net. You can only use valid ‘Levels’ that exist in SIMS.net. (You cannot add a new Level into SIMS.) Note that case is important, so ‘Gen’ is allowed, but ‘GEN’ will generate the error message! To solve it you need to use the ‘best fit’ Level if the exact Level is unavailable, or use ‘Gen’ (General) level (ie. non-specific level).

18. I get the error message “Incompatible database”

This usually means that you have entered the wrong SIMS password within TimeTabler (or the password has changed since you last exported).

Rather than telling you the password is wrong, SIMS produces a login box into which even if you enter the correct password, the “Incompatible database” error message can appear!

The solution is to type the new/correct password into the password box at the final step of the export from TimeTabler. The export should then be successful.

continued...
18. I get the message:
‘Some existing classes clash with other existing timetabled classes (2 instances)’ #1

We found this advice in a SIMS booklet:

Advice on Resolving Database Validation Errors

It is quite likely that some of these errors will be reported the first time you invoke the Curriculum Matching wizard. You will almost certainly be able to fix the problems using Database Diagnostics. If the problems reoccur later in the year, then you should consider informing your helpdesk, so that they can track down the cause of the problem.

Some Existing Classes are Timetabled Too Far into the Future
There are lesson records in the SQL database that have an indeterminate (NULL) end date. These must be trimmed back. Run Database Diagnostics to resolve this problem.

Some Existing Classes Clash with Other Existing Timetabled Classes
There are identical overlapping lesson records in the SQL database. These must be merged. Run Database Diagnostics to resolve this problem.

Some Existing Class Memberships Last Beyond the Last Academic Year
There are students whose class memberships persist longer than the latest planned academic year. These must be trimmed back. Run Database Diagnostics to resolve this problem.

NOTE: Database Diagnostics can be run by any SIMS .net user with System Manager permissions.

You run Database Diagnostics in SIMS.net by going to ‘Tools ➔ System Diagnostics ➔ Database Diagnostics’.

19. A school got the message:
‘Some existing classes clash with other existing timetabled classes’ #2

This school had already set-up their classes [teaching groups] in SIMS.net, and entered their students into those classes. Unfortunately the names they had used were not the same as the ones exported by TimeTabler!!
When they came to run the import, they were told that none of the classes being imported matched the existing classes.

In such a case it may be possible to change the Teaching Group Name (at Step 5 of the export), so that SIMS recognises the names ...but only if they exactly match.

The solution to this major problem is:

either: Do not allocate any students to teaching groups (classes) until after the timetable has been successfully imported,
or: Use the double-export method (see page 6 in this document),
or: Manually match the Groups on the Merge Curriculum Screen, see page 7.
20. I have used ‘free-format’ set names in TimeTabler – is this a problem?

   Problem:
   In TimeTabler, we allow free-format Set names of (up to) 5 characters.
   In SIMS.net, anything above 1 character can cause a problem (by breaking the maximum
   lengths of names, etc). Above 2 chars is quite likely to do this.

   Solution:
   The only solution is for you to manually alter your set names (eg. change ‘H&S’ to ‘HS’, etc).
   We highlight the problem in the export log ...we highlight any set-number over 2 chars.
   But to see whether this causes a problem in practice, look at your List of Teaching Group
   Names – any Teaching Group Name in red could be a problem.

21. The log says: ‘ERROR: Class contains reserved char <’

   SIMS.net uses a format called XML, and there are some characters that are ‘reserved’ in XML
   and cannot be used in your basic data. You will need to change your class name (or teacher or
   subject or wherever the problem lies).

22. I get the message ‘Illegal XML file’

   Same as the previous item – you have a character in your basic data which is reserved / illegal
   in XML. If you can’t spot it, please send your XML file to the HelpLine.

23. I get the message ‘You cannot timetable non-class periods’

   In SIMS.net, you can denote a period as ‘teaching’ or ‘non-teaching’.
   You must mimic this exactly in TimeTabler on the ‘Prepare Data’ screen (Step 3 of the export).
   You must also have the same number of periods in both systems. Eg. it would be no good
   saying you have 5 periods per day in TimeTabler, but 6 periods (inc. registration) in SIMS.net.
   So if you’ve included registration in SIMS.net, you must include it in TimeTabler too (use Check
   & Tidy Add a period if necessary).

   Any mismatch causes this error message.

   If you have the reverse situation then you must add the extra period in SIMS or block it off in
   TimeTabler (at Step 3 of the export).

24. What is the ‘Curriculum Matching Wizard’?

   This is a SIMS program that is called whenever you try to import into SIMS.net ... it manages
   the import, asks the relevant questions and takes the necessary steps to ensure the timetable is
   imported correctly.

25. Why am I being asked for a username and password?

   These are your SIMS username & password - you need to know these to access the Wizard.

26. What is the meaning of ‘linked’ and ‘unlinked’ items?

   On the ‘Submission Summary’ screen of the Wizard, there are columns titled ‘Linked’ and
   ‘Unlinked’. If this is your first export this year to SIMS.net, all structures should be counted as
   ‘Unlinked’. However, if you are re-exporting a timetable (an earlier version is already in
   SIMS.net) then you would expect to see figures in the ‘Linked’ column.

   continued...
27. I get double labels in SIMS like 7A.En1, 7A.En1/2 even though they are really both the same group of students

You have forgotten to add a Global DayBlock code as explained in part H of Export-Doc-1. You can check the labels by viewing the Report: Teaching-Groups.htm as explained in the first part of this trouble-shooting section (page 11).

28. On the Staff Timetable Screen in SIMS, a Room is missing (not displayed on the timetable).

You have got a Room in TimeTabler which is not in SIMS. A Room must exist in SIMS before the import starts, else it is ignored.

At the end of the export to SIMS there should be a message about unrecognised rooms and teachers if any exist on the timetable:

29. When I click on ‘Help’ in the Nova/SQL Transfer Wizard, nothing happens.

Solution: Copy the relevant SIMS HelpFile ‘CurrMatch.chm’ from the C:\program files\sims.net folder into the TimeTabler folder (which by default is at C:\TT4Win).

30. Throughout the import into SIMS .net the screen refers to ‘Nova’, instead of TimeTabler.

Ignore this, it is a trivial bug in SIMS .net.

31. How do I handle non-teaching periods ?

If you have any periods marked in SIMS.net as a “non-teaching period”, then you should not schedule a lesson into that period. If you do, you will get an error message when you import the timetable into SIMS.net. Most commonly, this happens when registration or lunch have been marked as ‘non-teaching periods’ in SIMS.net, but scheduled as lessons in TimeTabler.

For example, if in SIMS.net, Mon-period-1 is marked as a non-teaching period, then you cannot have a lesson on the timetable in Mon-period-1. But you can have ‘non-teaching activities’ – see item (1) above.

If you see this error when importing into SIMS.net, you should solve it in one of these ways:

a) Unassign the offending lesson(s) and then use ‘Staff Timetable Labels’ (‘PPA labels’) to mark these activities in TimeTabler, or

b) Use Special Locations instead of Classes, or

c) Use the ‘Shape’ screen (at Step 3 of the export from TimeTabler) to adjust the non-teaching periods, then export the ‘Cycle’ to SIMS.net, to update its idea of which periods are non-teaching periods.

NB. Whatever method you use, please look at the reg. periods in SIMS.net after importing, and make sure you (and the office staff, and people dealing with cover, etc) are happy with how they look, and with the shape of the day.

(As always, take a full backup of your SIMS database before importing, so you can return to where you were, if you need to change something).

32. My non-teaching activities appear on some screens in SIMS .net but not in others. What’s wrong?

This is a known bug in SIMS .net, which was identified in March 2009 and was then put on the SIMS .net ‘to do’ list. The path that does not show the non-teaching activities is: Reports|Print Timetables|Staff Timetables

continued...
33. In 2008 I inserted global day block codes throughout the sixth form to avoid getting duplicate teaching groups in SIMS.net. Is this still necessary?

You don’t need to manually add all the DayBlock codes now. It will be done automatically for you if, at Step 5 of the export, you click on ‘Set up Teaching Groups’ and then tick ‘Combine similar activities into one TG’. Note: The default is ticked, but you’d better make sure it hasn’t been unticked at some stage.

34. Registration periods and non-teaching periods. This year, for the first time I have entered the registrations into TimeTabler using a subject code Rg. The reason is purely to allow the admin staff to use SIMS-cover to cover registrations as well as ordinary lessons. What is the best way of dealing with these in the import? [See also item 38.]

a) Make sure your teaching and non-teaching periods are the same on each day (ie. Tues must not be different from Mon, etc) as SIMS does not handle differences between days.
b) SIMS will give an error message if you try to import a lesson into a non-teaching period.
c) from an import viewpoint, green (teaching) periods are safest - a cycle with all green periods should always import - but you have to balance that against what is needed for the Cover Module. On timetable printouts from SIMS all teaching periods will always appear, whereas you can choose whether Non-teaching periods are printed.

35. I am uncertain about getting the ‘eligibility’ right in the Sixth Form.

What I want is SIMS to give me nice 2-D tables for each Container Block in the Sixth Form. Do I turn off Sixth Form global eligibility when preparing the data for export?

Container Blocks are handled specially and should not need ‘Global eligibility’ so I would leave ‘Global eligibility’ unticked. If you do tick it, you are saying any student can be in any group, so it’s a drastic action. However, you can see what the effect is without having to complete the full import into SIMS, by clicking on ‘View Curriculum’ at Step 7 …this shows you the curriculum structure that will be exported to SIMS.net if you continue with the export.

36. I’ve imported the timetable successfully but when I try to view a teacher’s timetable for the ‘Current week’, his timetable is blank (no lessons appear).

You need to ‘Apply’ the timetable. You do this in SIMS as follows:
From the main page of SIMS, go to: Tools ➔ Academic Management ➔ Set Academic Year, then choose the appropriate Academic Year before doing: Apply Timetable.
Always take a Backup before you ‘Apply’ the timetable.

37. I have a fortnightly timetable, but when my school had a one-day holiday last Friday, I found that Friday’s timetable then appeared the following Monday, so now all the days of the timetable are out-of-synch with the real days of the week.

SIMS does not always cope well with holiday days, especially if your timetable is not a single week (5-day) one. So you have to ‘Apply’* the timetable one term at a time, choosing as your date range the first day of the term, and the last day of the term.

Note: Be extra careful when selecting these start and end dates, because when you apply the timetable it resets / deletes your lesson registers for the period you have chosen: any existing lesson attendance marks in that period will be deleted (!).

* For details of how to ‘Apply’ the timetable, see the previous item. Always take a Backup first.

continued...
38. Registration Periods

For more information about handling Registration Periods in SIMS, please see Appendix 3 in Export-Doc-2.pdf

39. Other reasons why data may not be exported.

a) The following data are not exported from TimeTabler:
   i) Any teacher whose full name is *D.
   ii) Any class whose printing name is *D.
   iii) Any composite class without a ‘SIMS band-letter’.

b) If there is a composite class on the Classes Screen in TimeTabler, but this class has no lessons on the schedule, you are asked: “The following classes have no lessons - do you want to include them in the export?” If you click ‘No’ (recommended) then these classes will not be exported.

c) If the structure of the school week is not the same in TimeTabler and in SIMS .net then the import is aborted by SIMS .net. You can export the TimeTabler cycle (the day & week structure) into SIMS .net as explained in section 4 above.

40. Other items to check

a) You must have entered your basic school information into SIMS.net before attempting the export. This means entering your teachers & students, setting-up your academic year, etc.

b) A timetable in SIMS.net is always associated with a particular range of dates - so make sure the ‘start’ and ‘end’ dates you enter in TimeTabler match the intended academic year (or part thereof) in SIMS.net. If you get it wrong it might over-write an existing timetable! In practice the latest date of an export should be no later than 31 July.

c) In SIMS.net, a subject must be exactly 2 characters long. The first character must be a CAPITAL letter and the second must be a lower-case letter or a digit. Therefore, during the export, TimeTabler will automatically convert “MATHS” to “Ma”, etc. However, you may have problems if this conversion produces duplicate subjects. For example, Physics and Philosophy both become Ph. If this happens, TimeTabler will warn you (see the Export Log).

d) Do any of your teacher initials have lower-case letters? SIMS doesn’t allow this, so TimeTabler will automatically convert ‘Ab’ to ‘AB’, etc. However, you may have problems if this conversion produces duplicate teachers. If this happens, TimeTabler will warn you (see the Export Log).

e) Some parts of this export rely on finding the lesson in its activity batch in TimeTabler. So if on the Edit Details Screen (see Section F20 in the TimeTabler Manual) you have any instances of ‘This lesson cannot be found in any of the batches currently linked to this Schedule’ ...then you may have a problem in SIMS.net.

f) If some of your timetable has not been exported, remember that Dummy (*D) teachers are ignored & omitted from the export. All special resources are also omitted. By default, Year 13 appears to be the highest year allowed in SIMS.net, so years above 13 are ignored.

continued...
41. Using a ‘Hosted’ version of SIMS

If you have a version of SIMS.net which is “Hosted”, then you can export to it from **TimeTabler**, in the usual way.

But Capita/SIMS tell us that you need to let whoever is in charge of the hosting (whether it be Capita itself, or they have recommended you use a third-party like SCOMIS) know that you will want **TimeTabler** to call the SIMS timetable import program, which is called “CurrMatch.exe”. You need to let them know this now / in advance of when you will need it, so they can set it up / be aware.

To quote Capita, they say that: “it needs to be explained that whatever computer has the **TimeTabler** application and the CurrMatch.exe needs to be connected to the hosted platform by the third party connector. It means that whichever local computer at the school where **TimeTabler** and CurrMatch.exe exist needs to have the third party connector”.

This information has to go to what Capita call “The Hosted Team”.

In summary, they say: “A school will inform the Hosted Team of the Partner application (ie. **TimeTabler**) it uses and a local integration box will be made available (by the Team)”.

If you have any problems or questions, or if your “Hosted Team” need more information, then please just ask them to contact us.

---

We would appreciate it if you could take the time to send us feedback on both:

- the **TimeTabler** export
- the SIMS .net import,

plus any comments about whether the export could be made better, for example to help at the stage of allocating students to classes in SIMS (using the ‘eligibility rules’).

Chris Johnson, Keith Johnson
support@timetabler.com

Our thanks to Jim Borchers and the many Users who have helped to improve this document.